CubieBoard博客-HomeCubieTech公司网站

CubieBoard中文论坛

 找回密码
 立即注册
搜索
热搜: unable
楼主: sgon00

完美解决Cubietruck高频电流噪音问题的方法 (原创)

[复制链接]

4

主题

0

好友

470

积分

禁止访问

贡献
94
金钱
167
威望
94
买家信用
卖家信用
积分
470
发表于 2014-11-7 00:17:55 |显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
回复

使用道具 举报

217

主题

23

好友

3万

积分

超级版主

Rank: 8Rank: 8

贡献
6362
金钱
13585
威望
6376
买家信用
卖家信用
积分
34206
发表于 2014-11-7 20:43:37 |显示全部楼层
本帖最后由 ahha007 于 2014-11-7 20:47 编辑

具体原理比较悬,遇到有问题的板子,可以参考一下以下两种方法:
1、接一个50欧姆的电阻到USB口的电源正负极,产生耗电100mA,此问题可以消除。
2、短路R66,(本身是NC的,CT背面留了一个0805的封装),也可以解决这个问题,但是那样就不支持锂电池供电的UPS功能了。
回复

使用道具 举报

12

主题

5

好友

4570

积分

论坛元老

Rank: 8Rank: 8

贡献
887
金钱
1577
威望
887
买家信用
卖家信用
积分
4570
发表于 2014-11-7 23:03:17 |显示全部楼层
ahha007 发表于 2014-11-7 20:43
具体原理比较悬,遇到有问题的板子,可以参考一下以下两种方法:
1、接一个50欧姆的电阻到USB口的电源正负 ...

哈哈,遇到有问题的板子可以返修不?
回复

使用道具 举报

12

主题

5

好友

4570

积分

论坛元老

Rank: 8Rank: 8

贡献
887
金钱
1577
威望
887
买家信用
卖家信用
积分
4570
发表于 2014-11-7 23:11:42 |显示全部楼层
实际上你这个问题很好解决,问题不是USB引起的,是电源适配器的共地隔离没有做好。你用高当一点的电源适配器就行了。
像我们搞音响工程的(唉,这年头啥都得弄),遇到这样的问题一般直接在音频输出级加一个隔离器,原理也不复杂就是一个变压器耦合电路,隔离两个系统之间的电压差。
你可以直接淘宝上买一个:http://detail.tmall.com/item.htm?id=40564341690
用不到那么麻烦插来插去的。
回复

使用道具 举报

217

主题

23

好友

3万

积分

超级版主

Rank: 8Rank: 8

贡献
6362
金钱
13585
威望
6376
买家信用
卖家信用
积分
34206
发表于 2014-11-8 00:21:11 |显示全部楼层
jerryli 发表于 2014-11-7 23:11
实际上你这个问题很好解决,问题不是USB引起的,是电源适配器的共地隔离没有做好。你用高当一点的电源适配 ...

关键是群众们反映不插耳机也会听到声音,貌似有点神奇的问题。
回复

使用道具 举报

12

主题

5

好友

4570

积分

论坛元老

Rank: 8Rank: 8

贡献
887
金钱
1577
威望
887
买家信用
卖家信用
积分
4570
发表于 2014-11-8 13:21:36 |显示全部楼层
ahha007 发表于 2014-11-8 00:21
关键是群众们反映不插耳机也会听到声音,貌似有点神奇的问题。

。。。。
你说的这种情况,很可能的地方就是电感线圈引起。我看CC-A80用的电感还真不少。
回复

使用道具 举报

0

主题

0

好友

487

积分

中级会员

Rank: 3Rank: 3

贡献
56
金钱
112
威望
156
买家信用
卖家信用
积分
487
发表于 2014-11-8 13:42:53 |显示全部楼层
jerryli 发表于 2014-11-8 13:21
。。。。
你说的这种情况,很可能的地方就是电感线圈引起。我看CC-A80用的电感还真不少。 ...

是的。由于在轻载PFM模式下,开关频率与电感共振了,感觉像一个很悬乎的问题。
回复

使用道具 举报

3

主题

0

好友

2046

积分

金牌会员

Rank: 6Rank: 6

贡献
349
金钱
697
威望
449
买家信用
卖家信用
积分
2046
发表于 2014-12-18 21:55:48 |显示全部楼层
ahha007 发表于 2014-11-7 20:43
具体原理比较悬,遇到有问题的板子,可以参考一下以下两种方法:
1、接一个50欧姆的电阻到USB口的电源正负 ...

老大。先感谢提供的学生价优惠,我的就遇到问题了。
电源是你们生产的2.5安那个。
在不上2.5‘HDD的时候,高频噪音比较小。但是一上硬盘,高频噪音就非常明显啊。怎么办
回复

使用道具 举报

3

主题

0

好友

2046

积分

金牌会员

Rank: 6Rank: 6

贡献
349
金钱
697
威望
449
买家信用
卖家信用
积分
2046
发表于 2014-12-19 13:52:00 |显示全部楼层
ahha007 发表于 2014-11-8 00:21
关键是群众们反映不插耳机也会听到声音,貌似有点神奇的问题。

好像高频电流的问题解决了。
硬盘装上去的话 ,高频电流声非常响。
但是在系统内只要装mount硬盘,让硬盘转动工作了。好像就好很多。
回复

使用道具 举报

2

主题

0

好友

265

积分

中级会员

Rank: 3Rank: 3

贡献
56
金钱
86
威望
56
买家信用
卖家信用
积分
265
发表于 2014-12-22 23:46:40 |显示全部楼层
我买了两个CubieTruck,都有同样的问题, 我的应用需要连接一个USB2.0的高速设备,经常访问出错导致无法正常访问,dmesg看到提示类似 Port Error(EMI?), re-enabling 的消息,搞的人焦头烂额的。出了这个错误只能重新启动,我试验了lubuntu,Cubieez都一样。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

QQ|Archiver|手机版|粤ICP备13051116号|cubie.cc---深刻的嵌入式技术讨论社区    

GMT+8, 2022-5-18 16:51 , Processed in 0.026039 second(s), 12 queries , Apc On.

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc. | Style by Coxxs

回顶部