CubieBoard博客-HomeCubieTech公司网站

cubie.cc CubieBoard中文论坛

 找回密码
 立即注册
搜索
热搜: unable
查看: 6457|回复: 10

(已解决)安裝 vsftpd

[复制链接]

4

主题

0

好友

309

积分

中级会员

Rank: 3Rank: 3

贡献
65
金钱
98
威望
65
买家信用
卖家信用
积分
309
发表于 2014-8-30 16:36:48 |显示全部楼层
本帖最后由 cubieplayer 于 2014-9-19 17:58 编辑

請教大家,我的板子了 cubieboard v2,裝了 Cubian-base-r5-a20.img,在安裝 vsftp 時會顯示
The following packages have unmet dependencies:
vsftpd : Depends: libc6 (>= 2.15) but 2.13-38+deb7u4 is to be installed
E: Unable to correct problems, you have held broken packages.

請問要怎樣才能將 libc6 更新至 2.15 以上的版本?

大約半年前我也有裝了一塊一樣的板子,但卻沒有這個問題…

回复

使用道具 举报

10

主题

1

好友

3603

积分

论坛元老

Rank: 8Rank: 8

贡献
682
金钱
1368
威望
682
买家信用
卖家信用
积分
3603
发表于 2014-9-1 15:50:45 |显示全部楼层
试试执行
sudo apt-get update & sudo apt-get upgrade
回复

使用道具 举报

4

主题

0

好友

309

积分

中级会员

Rank: 3Rank: 3

贡献
65
金钱
98
威望
65
买家信用
卖家信用
积分
309
发表于 2014-9-1 22:35:55 |显示全部楼层
請問這樣是從 stable 更新成 testing 嗎?
回复

使用道具 举报

10

主题

1

好友

3603

积分

论坛元老

Rank: 8Rank: 8

贡献
682
金钱
1368
威望
682
买家信用
卖家信用
积分
3603
发表于 2014-9-2 00:00:20 |显示全部楼层
seeing 发表于 2014-9-1 22:35
請問這樣是從 stable 更新成 testing 嗎?

不是,是都更新到stable。因为我今天更新发现libc6也更新了,所以你可以试试。
回复

使用道具 举报

4

主题

0

好友

309

积分

中级会员

Rank: 3Rank: 3

贡献
65
金钱
98
威望
65
买家信用
卖家信用
积分
309
发表于 2014-9-2 14:31:04 |显示全部楼层
我做了 sudo apt-get update & sudo apt-get upgrade 後,發現 libc6 沒有更新,要如何更新到 2.15 呢?

  1. cubie@Cubian:/var/run/mysqld$ apt-cache show libc6
  2. Package: libc6
  3. Source: eglibc
  4. Version: 2.13-38+deb7u4
  5. Installed-Size: 8106
  6. ...
复制代码
安裝 vsftp 仍然會出現

  1. The following packages have unmet dependencies:
  2. vsftpd : Depends: init-system-helpers (>= 1.18~) but it is not installable
  3.           Depends: libc6 (>= 2.15) but 2.13-38+deb7u4 is to be installed
  4.           Recommends: ssl-cert but it is not going to be installed
复制代码
回复

使用道具 举报

10

主题

1

好友

3603

积分

论坛元老

Rank: 8Rank: 8

贡献
682
金钱
1368
威望
682
买家信用
卖家信用
积分
3603
发表于 2014-9-2 20:41:26 |显示全部楼层
seeing 发表于 2014-9-2 14:31
我做了 sudo apt-get update & sudo apt-get upgrade 後,發現 libc6 沒有更新,要如何更新到 2.15 呢?安 ...

实在不行可以考虑自己编译一个,我以前编译过,还挺简单的。
回复

使用道具 举报

4

主题

0

好友

309

积分

中级会员

Rank: 3Rank: 3

贡献
65
金钱
98
威望
65
买家信用
卖家信用
积分
309
发表于 2014-9-3 11:33:16 |显示全部楼层
好吧,那我再找其它方法試試,謝謝您
回复

使用道具 举报

24

主题

10

好友

1万

积分

版主

Rank: 7Rank: 7Rank: 7

贡献
1924
金钱
3700
威望
1932
买家信用
卖家信用
积分
10040
发表于 2014-9-4 00:27:33 |显示全部楼层
seeing 发表于 2014-9-2 14:31
我做了 sudo apt-get update & sudo apt-get upgrade 後,發現 libc6 沒有更新,要如何更新到 2.15 呢?安 ...

debian稳定版比较保守,libc轻易不更新的
回复

使用道具 举报

4

主题

0

好友

309

积分

中级会员

Rank: 3Rank: 3

贡献
65
金钱
98
威望
65
买家信用
卖家信用
积分
309
发表于 2014-9-4 08:35:30 |显示全部楼层
cubieplayer 发表于 2014-9-4 00:27
debian稳定版比较保守,libc轻易不更新的

嗯,因為是要當 server 用的,希望越穩定越好,所以應該會繼續用 stable 的,不會更新到 testing。暫時先捨棄 vsftp,改用 pure-ftpd,不過 pure-ftpd 的登入時間很久,還是 vsftp 比較好用
回复

使用道具 举报

24

主题

10

好友

1万

积分

版主

Rank: 7Rank: 7Rank: 7

贡献
1924
金钱
3700
威望
1932
买家信用
卖家信用
积分
10040
发表于 2014-9-19 17:58:00 |显示全部楼层
seeing 发表于 2014-9-4 08:35
嗯,因為是要當 server 用的,希望越穩定越好,所以應該會繼續用 stable 的,不會更新到 testing。暫時先 ...

vsftpd不能安装是因为ajenti的源提供了一个新的vsftp,但是缺少相应的库,解决办法 1是去掉ajenti的源,2是直接指定版本安装
  1. sudo apt-get install vsftpd=2.3.5-3
复制代码
参见:https://github.com/cubieplayer/Cubian/issues/354
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

QQ|Archiver|手机版|邮件群发|cubie.cc---深刻的嵌入式技术和应用讨论中文社区 ( 粤ICP备13051116号-1  

GMT+8, 2019-11-21 17:17 , Processed in 0.021067 second(s), 8 queries , Apc On.

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc. | Style by Coxxs

回顶部