CubieBoard博客-HomeCubieTech公司网站

cubie.cc CubieBoard中文论坛

 找回密码
 立即注册
搜索
热搜: unable
查看: 1897|回复: 2

编译驱动问题

[复制链接]

2

主题

0

好友

290

积分

中级会员

Rank: 3Rank: 3

贡献
62
金钱
95
威望
62
买家信用
卖家信用
积分
290
发表于 2016-2-16 16:08:16 |显示全部楼层
按照教程
http://www.cubie.cc/forum.php?mo ... &extra=page%3D1
弄出现错误
工具链使用的是corsstool-ng(gcc version 5.3.0)
编译驱动时

make ARCH=arm CROSS_COMPILE=arm-linux- modules
.......
make[4]: *** [drivers/net/wireless/rtl8188eu/8188eu.o] 错误 1
make[3]: *** [drivers/net/wireless/rtl8188eu] 错误 2
make[2]: *** [drivers/net/wireless] 错误 2
make[1]: *** [drivers/net] 错误 2
make: *** [drivers] 错误 2

然后运行
make ARCH=arm CROSS_COMPILE=arm-linux- -j4 modules_install
INSTALL_MOD_PATH=/home/zzm/cubieboard2/build
无法获取"/home/zzm/cubieboard2/linux-sunxi/modules.builtin" 的文件状态(stat): 没有那个文件或目录



回复

使用道具 举报

74

主题

5

好友

1万

积分

超级版主

Rank: 8Rank: 8

贡献
3624
金钱
8301
威望
3632
买家信用
卖家信用
积分
19861
发表于 2016-2-16 16:56:14 |显示全部楼层
不要用这么新的编译工具,因为都没验证过的。用4.6就好了
http://linux-sunxi.org/Toolchain
回复

使用道具 举报

2

主题

0

好友

290

积分

中级会员

Rank: 3Rank: 3

贡献
62
金钱
95
威望
62
买家信用
卖家信用
积分
290
发表于 2016-2-21 16:31:29 |显示全部楼层
已经解决,linux_kernel.conf选错了
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

QQ|Archiver|手机版|邮件群发|cubie.cc---深刻的嵌入式技术和应用讨论中文社区 ( 粤ICP备13051116号-1  

GMT+8, 2019-6-20 13:43 , Processed in 0.026982 second(s), 12 queries , Apc On.

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc. | Style by Coxxs

回顶部